ConfigMgr 2012 R2 Management Point (Verwaltungspunkt) Installation schlägt fehl (ErrorCode: 1603)

Situation
Zur Ablösung eines System Center Configuration Managers 2007 (SCCM 2007) wurde beim Kunden ein System Center 2012 R2 Configuration Manager auf einem Windows Server 2012 R2 installiert. Die Installation ist ohne große Probleme von statten gegangen und alles sah anfangs recht gut aus. Nach einer Zeit traten jedoch einige Fehler auf, welche ich in diesen Artikel beschreiben möchte.

 

Fehler (Betriebssystemverteilung)
Beim ersten Test der Betriebssystemverteilung fällt auf, dass der Client zwar Kontakt zum PXE – Server (WDS) aufnimmt, jedoch kein WIM-BootImage herunter geladen wird. Im PXE-Log (smspxe.log) ist erkennbar, dass der Management Point (MP) nicht erreicht werden kann.
(Info vorweg: Die Neuinstallation des PXE-DistributionPoints, welche in vielen Artikeln vorgeschlagen wird, löste das Problem bei mir nicht.)

clip_image001

Failed to get information for MP: http://sccmserver.domain.loc. 80004005.SMSPXE
PXE::MP_InitializeTransport failed; 0x80004005
PXE::MP_LookupDevice failed; 0x80004005

 

Fehler (Neuinstallation des Management Points)
Installiert man den Management Point neu (Entfernen und Hinzufügen der Rolle), so schlägt die Installation fehl.

Im Setup-Log (mpSetup.log) ist erkennbar, dass die Installation mit dem ErrorCode 1603 fehlschlägt. Diese Fehlermeldung bedeutet „Critical Error“ und ist daher leider nicht sehr aussagekräftig.

clip_image002

Installing the SMSMP
Passed OS version check.
IIS Service is installed.
No versions of SMSMP are installed. Installing new SMSMP.
Enabling MSI logging. mp.msi will log to D:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log
Installing D:\Program Files\Microsoft Configuration Manager\bin\x64\mp.msi CCMINSTALLDIR=“D:\Program Files\SMS_CCM“ CCMSERVERDATAROOT=“D:\Program Files\Microsoft Configuration Manager“ USESMSPORTS=TRUE SMSPORTS=80 USESMSSSLPORTS=TRUE SMSSSLPORTS=443 USESMSSSL=TRUE SMSSSLSTATE=0 CCMENABLELOGGING=TRUE CCMLOGLEVEL=1 CCMLOGMAXSIZE=1000000 CCMLOGMAXHISTORY=1
mp.msi exited with return code: 1603
Backing up D:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log to D:\Program Files\Microsoft Configuration Manager\logs\mpMSI.log.LastError
Fatal MSI Error – mp.msi could not be installed.
~RoleSetup().

 

Mit Hilfe des Detail-Logs der Management Point Installation (mpMSI.log) kann die folgende Ursache (rot) ausgemacht werden:

clip_image003

ERROR: Failed to compile migrated pre-V4 Beta 2 policies. Error 8004400A, lines 0 – 0
Policy settings migration failed.
CustomAction CcmMigratePolicySettings returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

 

Ursache
Bei der Grundinstallation des Windows Server 2012 R2 hatte sich ein SCCM 2007 Client durch die automatische Verteilung auf dem Server eingeschlichen. Dieser wurde Ordnungsgemäß vor der Installation des ConfigMgrs 2012 R2 entfernt. (Natürlich wurde auch der automatische Client-Push des SCCM 2007 deaktiviert.) Trotz der Deinstallation des SCCM 2007 Clients scheint dieser noch einige Policy-Reste hinterlassen zu haben, welche die Management Point Installation nicht verarbeiten kann. Aufgrund dessen konnte sich der Management Point nicht richtig installieren.

 

Lösung
Da die Management Point Installation das Problem, welches der SCCM 2007 Client ins Leben gerufen hat, nicht beseitigen kann, muss der neue ConfigMgr-Client (2012 R2) auf dem Server installiert werden, da dessen Installation in der Lage ist die Altlasten des 2007er Clients zu beseitigen. Ohne einen funktionierenden Management Point muss der neue Client jedoch mit bestimmten Parametern ausgeführt werden, damit die Installation durch läuft. Bevor dieser jedoch installiert wird, sollte die Management Point Rolle (Verwaltungspunkt) entfernt werden!

Client-Installation:

ccmsetup.exe /forceinstall /source:“%ProgramFiles%\Microsoft Configuration Manager\Client“ SMSSITECODE=PS1

(Das Source-Verzeichnis und der SiteCode müssen entsprechend angepasst werden!)

Nach der Installation des Clients kann der Management Point (Verwaltungspunkt) wieder als Rolle hinzugefügt werden. Die Installation läuft jetzt erfolgreich durch. (Kontrolle mit Hilfe des Setup-Logs „mpSetup.log“)

Bauer Jürgen

Vielen Dank!
Der Artikel betraf genau unser Problem!
Leider haben wir mit dem MP das nächste Problem. In der mpcontrol.log steht der Fehler beim HTTPRequest 503 „Service Unavailable“.
Irgendwie macht der IIS Stress. Die Anwendungspools beenden sich. Dies scheint mit falschen oder fehlenden Sicherheitsrechten zu tun haben.
Bisher haben wir aber keine Lösung gefunden.

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.